情シス特化型メディア SYSZO

投稿日時 - 2009.05.18 10:56:31

くろさん

solaris2.6

お世話になります。

SPARC系のマシンにSolaris2.6で
動作させているシステムがあります。
このマシンは、8年近く経過しており、
メーカーの保守も終了してしまいました。
通常ですとマシンを交換し、OSを上げて移行したり
仮想化とするのでしょうが、動作しているシステムが
Solaris2.6でないと動きません。

OSはこのままでVMWareを用いて仮想化しようと思いましたが、
メーカーから保証できないので不可能という回答をもらいました。
システムをリプレースして、新しい環境で動くようにすれば
いいのですが、費用が高額(数千万円)になるため、
弊社の規模では、この予算を確保することが難しいです。

solaris2.6を新しいマシンで動かすことを
ご存知の方がいらっしゃいましたら、教えてください。

以上、宜しくお願いします。

0
いいね
2009.05.18 14:27
systemさん
こんにちは。

Solarisコンテナは試されたのでしょうか?
もしSolaris 10が駄目だとしてもSolarsi 8/9上では動くかもしれません。

あとappcertで検証してみてはいかがでしょうか?ソースがあれば修正も可能かもしれないですし、Solaris ABI準拠であれば、Sunがマイグレーションの支援をしていたと思います。
0
いいね
コメントする

ログインしてからコメントできます

急上昇ワード

更新2017.05.28 19:21

SYSZO応援企業