質問

2016年08月29日 14時22分
  • アプリの対応OSバージョンについて

質問

Androidの社内アプリを作る必要がありますが、最新版は別として4.0.3 といったカナリ古い端末も使う想定の人に存在しています。

出来れば4.4.4以上としたいのですが、
対象に含まない、ITリテラシーが低くても理解できる説明は思い付きませんでしょうか?

普通であれば、バージョンのシェアの割合で切りますが、それでは難しいようで困っております。

2016年08月29日 14時22分

4件の回答があります

回答

皆さん、ありがとうございます!

>BBさん
コスト的には社内リソースなので、作ったほうが良いのですが、(簡単な物なので)
OS対応が入るとコスト感が逆転してくるので考えものなところです。。。

>railroadさん
なるほどです。
そのアプローチ、相手のリテラシー的に良さそうなので使わせていただきます!

>のりおさん
私物なので困ったところです。。。
コストの差分で買い換えてあげれそうですが、そうもいかずw

>sysjojoさん
順当に行くとこの辺りなんですが、そこら辺を理解してもらえないので困っている次第です。。。

2016年08月29日 21時26分

回答

会社貸与のスマホなら会社の経費で更新しちゃうのもアリかなって思います。うちの場合、個人携帯で業務アプリ動かすのは禁止にしています。

2016年08月29日 16時51分

回答

Android4.4.4でしたら、ちょうどポケモンGoが対応しているか否かの境界線のラインに近いので、それを交えた説明でいかがでしょうか。

「ポケモンGoに対応していない端末だとちょっと…」みたいな風でいかがですか?

2016年08月29日 14時49分

回答

社内アプリであれば、Androidバージョンは強気に切っていいのではないでしょうか。
リリース後は改善・改修をしていくかと思いますが、
対応バージョンを増やすとそれだけ開発・テスト工数は増えるので非常に大変かと思います。

どのようなアプリかはわかりませんが、業務システム系アプリであれば可能な限り自社アプリを開発しないで
既存製品(アプリ)の中からマッチしたものを選ぶ方をお勧めします。

今後の開発・運用コストに比べれば、既存製品のライセンス費用の方が絶対に安いと思います。

2016年08月29日 14時47分

あなたもコメントしましょう!