質問

2016年05月18日 14時33分
  • ネットワークが不定期に著しく遅くなる

質問

こんにちは。
ネットワークが不定期に著しく遅くなる現象に悩まされています。

使用回線:フレッツ光

機器構成は以下の通りです。
ONU(GE-ONU)
 ↓
VG8301ゲートウェイ装置SX「1」
 ↓
Fortigate FGT60D
 ↓
LAN

フレッツ光を使用していますが、USENのスピードテストで大体10~20Mbps程度しかでません。
それはまだよいほうで、不定期に測定不能な状態に陥ります。
そうなるとインターネットアクセスも体感上も激しく遅くなります。

NTTにも問い合わせましたが、NTTの範疇では特に問題は起こっておらず
御社内(つまり弊社)のLAN環境の問題ではないかとの見解を頂いています。

こういった場合、どんなアプローチをとればよいでしょうか。

まずは、ボトルネック原因の特定を行いたく、
次に特定できた場合のアプローチをしたいです。
(ボトルネックがどこなのかによると思いますが)

よろしくお願いします。

15件の回答があります

回答

遅くなるのはインターネットで、社内のファイルサーバへのアクセスは問題ございません。

というのであれば やっぱりインターネットの出口でログ(というかトラフィック監視)がほしいですね。
前述のように 私はトラフィック監視でアンチウィルスソフトの不具合でとてつもないトラフィックが発生しているのを見つけました。 (だからといって今回もそれが原因です というとではありません)

私の後任の後任なんか「トラフィック監視? そんなものやらなくてもいいですよ 今は前の回線の10倍ですから、多少、データが増えたって止まりはしないですよ」などと言っています。 でも、監視していないと”突然、パンク”ですから怖いです。(と言っても理解しない)

2017年09月19日 16時57分

回答

御社内でWEBサーバ、特にWordpressでWEBやブログの公開はされておりますでしょうか。(テスト用、開発中も含む)
WEB公開をされている場合、ファイヤーウォール機器は通過するのでログ等も不審なものは残らないと思われます。

Wordpressは攻撃を受けやすく、攻撃を受けている間は攻撃者とWEBサーバーの応答の通信で帯域が占拠されるため、遅く感じると思います。
該当した場合はWordpressの簡単なセキュリティ対策で改善が見込めると思います。

2016年05月20日 12時42分

回答

Fortigate60Cを使用していた私の担当先でも同様の事象がありました。
遅くなるときは決まって、Fortigateのメモリー使用率が100%近くではりついていました。
暫定的にはFortigate再起動で解消、恒久対応としてファームウェアをアップデートしてからは発生していません。

2016年05月19日 11時42分

回答

Fortigate60Cを使用していた私の担当先でも同様の事象がありました。
遅くなるときは決まって、Fortigateのメモリー使用率が100%近くではりついていました。
暫定的にはFortigate再起動で解消、恒久対応としてファームウェアをアップデートしてからは発生していません。

2016年05月19日 11時28分

回答

ナイス笑顔さん
アドバイス頂き、ありがとうございます。
弊社ではProxyは使用していないため、ウィルスソフト等が怪しそうです。
色々な意見が拝見できましたので、私も参考にさせて頂いて原因を絞っていこうと思います。
進展がありましたら、共有させて頂きます。

2016年05月19日 09時26分

回答

投稿主です。

みなさん、この短時間にたくさんのアドバイスや経験談などをいただき、本当にありがとうございます。
同じような現象で今まさに悩まれている方もいらっしゃり、励まされました。

不定期に発生し、その現象にもムラがあるというところで、まずは社内からのネットワークトラフィックにフォーカスをあてて調査してみたいと考えました。
そこでひとまずは、Fortiでトラフィックのログを取るということをしてみたいと考えています。
ただ、Fortiを導入したのが前任者で、私自身あまりよくわかっていない状況の為、書籍を購入してやってみたいと思います。

また進展がありましたら共有させていただきます。

2016年05月19日 08時36分

回答

セキュリティエンジニアです。

社内で利用しているクライアント台数(PCだけでなく、複合機、サーバ、アクセスポイントや繋がってるスマホ等のスマートデバイス)はいかがでしょうか? 利用しているUTM(forti)の推奨利用台数に納まっていますでしょうか?

UTMで全ての機能は使っていますか?FW,IPS,アンチウィルス,アプリケーションコントロール,アンチスパム等。UTMで全ての機能を使っている場合はスループットが下がりますので、利用環境に合わせてサイジングが適切かを確認しましょう。UTMの場合チューニングや、ファームウェアによっても変わってきます。一部機能を一時的に切ったり、ルーターにネットワークを直結すると結果が出るでしょう。(その間セキュリティレベルは低下しますのでご注意ください)

2016年05月18日 22時36分

回答

同じような事象の時にファームウェアのアップデートで改善したことがあります。

2016年05月18日 19時25分

回答

いろんな意見がありそうですが私なら次なプローチを取る気がします。
①Fortigateを調べる
②通信経路を特定する
③経路上の機器を調べる
④ハブを別のものと交換(もし使っていれば)
⑤LANケーブルを交換
⑥クライアントPCの調査

FortigateのIPSやアンチウィルスが有効だとスループットが下がるのでもし可能なら無効して変化がないか調べると良いと思います。カタログ値だと IPSが200Mbps、アンチウィルスは 30/50 Mbps だそうです。また Fortigateの管理画面でCPU負荷や、帯域を使い潰している通信が無いか 外部からの攻撃(Ddos攻撃や大量のスキャニング)がないかなど合わせて確認すると良いと思います。

LAN内に問題がある場合は、インターネット接続に限らず遅延が起きると思いますので 通信経路を特定して 経路上のものを調べる必要があります。ある程度の規模以上のLANだと、経路を特定するのが大変だと思いますので、Smokeping のようなツールでモニタリングするのが良いと思います。 ツールが使えない場合は、現象が出ている時にどこからどのへの通信が遅延してるか Ping や Httpで調べるしか無いかなという気がします。スイッチでポートをミラーして、パケットアナライザーでログを取るのも原因特定に役立つ可能性があります。

経路が特定できたら経路上の機器のログやステータスを確認して 故障がないか調べます。もしインターフェースのエラーやCRCのカウンタが増えていたら怪しいです。その機器に問題がなければ対向の機器が怪しいです。ケーブル、メディアコンバータ、ハブなどが原因の可能性があります。可能であれば別のものと交換してみて変化がないか調べるのも良いと思います。

最後はクライアントPCですが、オンラインストレージと同期させたりしてると遅くなるので インストールしてるアプリを見て、インターネットセキュリティを無効化したり、セーフモードで試したりして 変化がないか調べます。

2016年05月18日 18時52分

回答

Windows Updateやウイルスパターン配信で遅い可能性もありますね。

切り分けするのであれば、上流の機器にケーブル差し替えていけば分る。

>ばっつさん
>不思議なのが、外部サイトへの接続は遅いのに、インターネットVPNである社内は遅くならないことですよね。

外部サイトへの接続が遅いのは、Proxyが影響する事もありますよ。外部要因だと拠点間の経路も遅延には関係しますしね。(拠点間はプロバイダー同じだったり、要因はあるのではないでしょうか)

2016年05月18日 17時22分

回答

乱暴な方法としては 「遅くなったな」という時にルータの線を抜いてしまう
そのときに文句を言ってきたものが犯人かも (「SNSに動画をアップしていたんだよ」とかね)

まぁ冗談はさておき
ウチでは 某アンチウィルスソフトを使っていましたが、1時間ごとにそのソフトの管理サーバ(ウィルスデータの配布を行っている)からとてつもないインターネットへのアクセスがありました。当時の情シス員はそれを解決できずに「インターネットが切れるわけではないのでいいんじゃないですか」などと悠長な事を言うので叱りとばしました (原因は管理サーバのソフトが古く、ウィルスデータの更新に失敗していたためでした)
私がそれを判ったのはインターネットへのアクセスログを収集していたからですが、当の情シス員はそれさえもやっていませんでした。)
インターネットへのアクセスログもしくはトラフィックをグラフにすると何かわかるかもしれませんね

2016年05月18日 17時04分

回答

弊社も同じ現象で悩まされていました。同じくNTTに調査依頼したものの、工業地帯、かつ、ベストエフォートなので・・という回答でした。
現象が発生している状況で直接基地局内で調査してもらったのですが、
原因は分からず・・でした。
結局、原因は不明なまま「隼」に乗り換えることで改善され終わりました。
こんな感じだったので正直、基地局側はホントに大丈夫なの?と邪推してしまいますね。

改善されたのは良かったのですが、1年ほどたった現在、当時ほどと言えないまでも遅くなる時がまた発生し始めました。
不思議なのが、外部サイトへの接続は遅いのに、インターネットVPNである社内は遅くならないことですよね。
単純にハブの過負荷や回線自体の負荷とは言い切れないのが難しいです。
進捗としては弊社でも原因を探っているところです。

2016年05月18日 17時02分

回答

参考になるかどうかわかりませんが、

以前、AWSとCISCOのVPNルータの間で速度が著しく低下することがある事象を経験したことがあります。

このケースでは、CISCOの新ルータの設定が足りなかったという結論でした。

機器設定も確認するのも如何でしょうか。

2016年05月18日 15時51分

回答

事象が全社的に発生しているのか、一部の島だけで発生しているのかが最初の判断基準になります。

全社的に発生しているのであれば、島ハブからルータまでの各機器に直接PCをつないで、どこで遅くなっているかを見極める、というのはいかがでしょうか。

「不定期に」とありますが、実際は曜日や時間といった何かしらの法則があるかもしれません。
Zabbix などの無料で使える監視ソフトを入れて、ネットワーク機器のデータ通信量を取ってみるというのも傾向をつかむためには良いかもしれません。

以上、ご参考になれば幸いです。

2016年05月18日 15時34分

回答

追伸です。
遅くなるのはインターネットで、社内のファイルサーバへのアクセスは問題ございません。
よろしくお願いします!

2016年05月18日 15時13分

あなたもコメントしましょう!